Code "Silence" - Problème modification taille des avatars 340

Terrible

Bienvenue sur Terrible, le forum de libre-service pour vos codages de forums. Venez trouver ici toutes sortes de codes pour agrémenter aussi bien vos templates que vos messages, sans avoir besoin d'inscription !

Terrible :: Terrible, des codages pour vos forums en libre service :: Administration :: Problème avec un code
avatar
Random
le Mer 26 Déc - 22:35
Bonsoir !

Code concerné par le problème : Lien

Décrivez votre problème : Je cherche à utiliser ce code avec des avatars 250*350 px. Problème, ça n'a pas l'air de marcher. Est-ce parce que mon forum est trop petit (850 px) ? Pour information, j'ai utilisé le codage complet de votre LS index (et je n'ai rien d'autre en terme de codage sur le forum).

Lien vers votre forum (endroit du problème) : Lien

Merci d'avance pour votre éclairage ! :)

P.S. : J'avais pas vu cette section et ai posté directement à la suite du code. Toutes mes excuses. ;w;
(Du coup j'me permets de le reposter ici, afin d'être dans les clous héhé).
Awful
le Dim 10 Fév - 0:22
Coucou !
Le message date un peu vu qu'on est le 10 février aujourd'hui, je suppose que le problème doit être résolu depuis ? Ou non ? ;o;
avatar
Random
le Mar 12 Fév - 21:32
Bonsoir !

Finalement, je suis passée à une taille plus basique.
Cependant, j'ai un souci provenant du kit forum #2 : une bande verte apparaît légèrement sur le côté droit. J'avais eu le souci précédemment et avais créé une nouvelle div pour la fiche de présentation (qui s'est déformée suite à ma suppression d'une valeur ayant corrigé le souci). Mais désormais, pour une raison que j'ignore, elle est réapparue.

Lien d'un sujet (ça le fait pour tout message du genre) : http://lost-twinkle.forumactif.com/t3-1-concept-et-regles

Merci d'avance (je ne sais pas si je devais recréer un topic, auquel cas désolée ;w; )
Awful
le Mar 12 Fév - 22:46
Bonsoir !

Aucun souci, je peux répondre ici :3

Je constate qu'il y a un petit souci de padding dans mon codage, je devrais revoir ça. La bande verte qui apparaît est en fait la couleur de fond initiale. Le bloc est plus grand de deux pixels que l'image, c'est pour ça. Tu peux régler ça en ajoutant ces propriétés à .kit-head dans ton CSS :

Code:
.kit-head {
    width: 450px;
    margin: auto;
}
avatar
Random
le Jeu 14 Fév - 18:40
OOOOH. Merci, ça marche ! Yeah

Je te remercie pour ta réactivité, belle soirée !
avatar
Random
le Ven 15 Fév - 14:25
Re-bonjour !

Je me permets de DP car je n'avais pas réadapté pour la fiche de présentation. Maintenant que c'est fait, j'ai pour mes messages administratifs des bandes plus larges à gauche et à droite de l'image que celles du haut et du bas.

Voici un p'tit lien : http://lost-twinkle.forumactif.com/t3-1-concept-et-regles
Du coup je comprends pas trop comment faire. Cry forever

Merci d'avance et désolée de l'embêtement. :(
Awful
le Sam 16 Fév - 11:23
Re-bonjour et aucun souci, ça ne m'embête pas, je suis là pour aider !
Je te propose de changer très légèrement le padding de .kit-wrap pour que la taille du bloc s'adapte exactement à celle de ton image, en outre, 450px :
Code:
.kit-wrap {
    padding: 24px;
}
Normalement ça ne devrait pas trop bousculer ta mise en page et régler ce souci de bandes c:
avatar
Random
le Sam 16 Fév - 17:01
Bonjouuur !

Quand je fais cette manip', il y a toujours du blanc de chaque côté pour les messages administratifs, et la fiche de présentation a carrément l'illustration qui sort du cadre : http://lost-twinkle.forumactif.com/t2-modele-fiche-de-presentation

Encore merci pour l'aide apportée !
Awful
le Dim 17 Fév - 11:21
As-tu bien installé le CSS qu je t'ai donné ? Je ne le vois pas apparaître dans l'inspecteur.
Dans ton CSS, retire :
Code:
.kit-head {
    width: 450px;
    margin: auto;
}
(le code que je t'avais donné plus haut)

Et ajoute :
Code:
.kit-wrap {
    padding: 24px;
}
.kit-app {
    padding: 20px;
}
avatar
Random
le Dim 17 Fév - 23:18
Bonsoir !

Oui j'avais tout enlevé vu que ça décalait, désolée. ><
J'ai rajouté ce que tu m'as donné et j'ai toujours la fameuse bande sur le côté. Pour la fiche de présentation, plus rien n'est décalé. Par contre, que ce soit sujet administratif ou fiche de présentation, le sous-titre est complètement décalé vers la gauche. :/
avatar
Random
le Sam 2 Mar - 2:35
Bonsoir !

Juste pour avertir que mon problème est finalement résolu ; il fallait simplement mettre une image de 458 px de largeur au lieu des 450 annoncés et... magie !

Désolée d'avoir fait mon boulet, haha. Et merci de l'aide apportée, à bientôt ! Yeah

*disparaît dans un buisson*
Awful
le Mer 6 Mar - 11:03
Du coup c'est bon, plus de soucis ?
avatar
Random
le Jeu 14 Mar - 2:07
Bonsoir !

J'ai relevé deux soucis que je n'arrive pas à résoudre :

Code "Silence" - Problème modification taille des avatars 1552525061-sujet
Le premier la partie gauche est plus épaisse que la partie droite.

Code "Silence" - Problème modification taille des avatars 1552525061-cat
Le deuxième forum (avec le dernier message posté par "Random") est davantage descendu vers le bas que le forum du haut. Peut-être car la police du dernier posteur est plus grande ? Je ne sais pas comment régler ça.

Voilà, désolée. :(
Contenu sponsorisé
Permission de ce forum:
Vous pouvez répondre aux sujets dans ce forum