Terrible

Bienvenue sur Terrible, le forum de libre-service pour vos codages de forums. Venez trouver ici toutes sortes de codes pour agrémenter aussi bien vos templates que vos messages, sans avoir besoin d'inscription !


Terrible :: Terrible, des codages pour vos forums en libre service :: Administration :: Problème avec un code :: Problèmes résolus
piou
le Mar 20 Mar - 1:41
Bonjour :)

Je suis en train de mettre en place mon forum rpg (bon je démarre la mise en place, ne pas faire attention à l'apparence qui du coup est un gros chantier...) et j'ai rencontré un problème avec l'un de tes codages en libre-service.

Code concerné par le problème : Lien

Décrivez votre problème : j'ai voulu utilisé le code de sidebar que tu propose, mais celle-ci ne se ferme pas. Je précise que pour l'instant je n'ai absolument rien touché au code et au contenu, je l'ai juste copié/collé.

Lien vers votre forum (endroit du problème) : Lien

Merci par avance et j'en profite pour te féliciter pour tous ce beau contenu en libre-service ! Il est d'une grande aide.
D'ailleurs je précise que le lien de Terrible et dore et déjà dans les crédits :D

Ps: quand le forum aura un peu plus avancé dans sa construction, je te passerais peut-être des commandes pour m'aider à finaliser son apparence (car oui je suis une quiche en codage...)
avatar
le Mar 20 Mar - 10:13
Bonjour Piou !
Tout d'abord, merci beaucoup °u° Et ensuite, aucun souci, je désespère de voir quelqu'un poster dans la partie commandes, alors je t'invite à le faire haha /pan

Bref, passons à ton problème : as-tu bien mis en place le javascript et bien coché "oui" dans "Activer la gestion des codes Javascript" ? J'ai inspecté le code de ton forum et j'ai l'impression de ne pas voir le js associé, du coup le souci vient probablement de là °°

Je te laisse voir ça et me répondre c:

(Et bon courage pour la construction de ton forum, au passage ! °u° )
piou
le Mar 20 Mar - 11:41
Bonjour Awful,

Il est visiblement très mauvais pour moi d'essayer de coder en pleine nuit d'insomnie... car il semble que j'ai effectivement oublié de cocher cette petite case... Mille fois pardon pour cette stupide erreur ! Enfin merci du sauvetage !

Et dès que j'aurais un peu plus en tête les maquettes pour harmoniser ce qu'il me manque en codage je te passerais, pour sûr, commande. Mais pour l'instant je me concentre un peu sur le contenu, car mine de rien la zone RP n'a pas encore été créer...

Bref j'arrête de t'embêter avec tout ce bavardage et te souhaite une bonne journée :D

(merci pour les encouragements !)
avatar
le Mar 20 Mar - 11:50
Ne t'excuse pas, ça arrive à tout le monde, aucun souci xD Ravi que le problème soit réglé, en tout cas !
Je te dis à bientôt dans ce cas, et au moindre souci, n'hésite pas~°u°

Bonne journée !
piou
le Jeu 22 Mar - 16:13
Bonjour Awful,

J'en profite pour savoir s'il est possible de faire en sorte que la barre ne s'ouvre pas en permanence dès qu'on recharge une page ?
En l'état c'est un peu contraignant pour les plus petits écrans de devoir en permanence la refermer. Cela ne me dérange pas si pour ce faire la barre doit être fermée en position initiale.

Merci d'avance :)

(Ps : je vais travailler sur mes maquettes de codage aujourd'hui, donc tu risque de voir bientôt une commande débarquer !)
avatar
le Jeu 22 Mar - 16:47
Hello Piou !
La solution facile est la suivante :
Au tout début de ton javascript (deuxième ligne), remplace :
Code:
$("#sidebar-trigger").addClass('active');

Par:
Code:
$('#sidebar').css('left', '-260px');
$("#sidebar-trigger").removeClass("active");

Et ça devrait fonctionner, dis-moi s'il y a un souci !
(Et merci de la suggestion au passage, je vais ajouter l'option dans le code xD)
piou
le Jeu 22 Mar - 17:07
Alors quand j'applique la modification du code, ça me retire l'option de fermer la sidebar...
L'idée c'est de pouvoir toujours la fermer pour les petits écrans chez qui ça mort sur le corps du forum, mais ne pas avoir à le faire à chaque fois que l'on charge une nouvelle page.
avatar
le Jeu 22 Mar - 17:13
Hm, j'ai l'impression que tu n'as pas bien placé le javascript.
Tu l'as bien modifié dans Modules > HTML & Javascript > Gestion des codes Javascript ?
piou
le Jeu 22 Mar - 17:20
Décidément je ne suis pas douée avec les emplacement et les petits détails pour le codage...
Du coup j'ai remis à la bonne place et ça fonctionne :D
avatar
le Jeu 22 Mar - 17:26
Ouf, tant mieux ! °u°
N'hésite pas si tu as encore besoin d'aide !
Contenu sponsorisé
Permission de ce forum:
Vous pouvez répondre aux sujets dans ce forum